Welcome! Please see the About page for a little more info on how this works.

0 votes
in Errors by

Hey, i`'m still very green in clojure and Java but i want to use this git repo https://github.com/setzer22/alignment_model_text .

when i execute the Installation script i get the followign error:

 [INFO] --- clojure-maven-plugin:1.8.4:compile (clojure-compile) @ modelvsdocument ---
Compiling edu.upc.modelvsdocument.extraction.common to /home/user/alignment_model_text-master/modelvsdocument/target/classes
WARNING: boolean? already refers to: #'clojure.core/boolean? in namespace: clojure.tools.analyzer.utils, being replaced by: #'clojure.tools.analyzer.utils/boolean?
WARNING: boolean? already refers to: #'clojure.core/boolean? in namespace: clojure.tools.analyzer, being replaced by: #'clojure.tools.analyzer.utils/boolean?
Exception in thread "main" java.lang.RuntimeException: Unable to find static field: IDENT in class edu.upc.Jfreeling.AnalysisLevel, compiling:(edu/upc/nlp4bpm_commons/Freeling.clj:51:8)
        at clojure.lang.Compiler.analyze(Compiler.java:6720)
        at clojure.lang.Compiler.analyze(Compiler.java:6657)
        at clojure.lang.Compiler$MapExpr.parse(Compiler.java:3072)
        at clojure.lang.Compiler.analyze(Compiler.java:6709)
        at clojure.lang.Compiler.analyze(Compiler.java:6657)
        at clojure.lang.Compiler$InvokeExpr.parse(Compiler.java:3767)
        at clojure.lang.Compiler.analyzeSeq(Compiler.java:6921)

So i googled and tried to fix that, but i'm not really sure about the exact problem.

Does anyone know what causes such an error? And maybe have some tips to solve this?

Thank you very much!

1 Answer

+1 vote
selected by
Best answer

Well, I don't know anything about this project, but it's saying that in edu/upc/nlp4bpm_commons/Freeling.clj (which is under nlp4bpm_commons/src/main/clojure/ in the repo), that Clojure code refers to a static field AnalysisLevel/IDENT in class edu.upc.Jfreeling.AnalysisLevel and finding that that field doesn't exist.

AnalysisLevel is a class in the Java jar local-jars/Jfreeling.jar. which does have that class with that field, so if I had to guess, maybe there was a missed step in that (pretty weird) install procedure?

First, thank you for your reply and your help:)

 I changed the version of the library "Freeling" and now the error has disapeared...

So, this Question could be marked as "solved"
Papagenue -- you can mark an answer as "Best answer" by clicking the check mark next to it (on the left). You can also vote for an answer if you want (just about the check mark are the voting up/down buttons). I have marked this as "Best answer" for you since you said it is solved.