Share your thoughts in the 2021 Clojure Community Survey!

Welcome! Please see the About page for a little more info on how this works.

0 votes
in REPL by
edited by

I am trying to work through an example in the Clojure Workshop. I created a folder and in that included the following project.clj file.

(defproject learncsv "1.0.0-SNAPSHOT"
 :dependencies [[org.clojure/data.csv "1.0.0"]
             [semantic-csv "0.2.1-alpha1"]])

Then, I went to the terminal and typed

lein repl

I got the following error:

OpenJDK 64-Bit Server VM warning: Options -Xverify:none and -noverify were deprecated 

in JDK 13 and will likely be removed in a future release.
As of 2.8.2, the repl task is incompatible with Clojure versions older than 1.7.0.
You can downgrade to 2.8.1 or use `lein trampoline run -m clojure.main` for a simpler 
 fallback repl.
Subprocess failed (exit code: 1)

I am super new to clojure. Never included any dependencies. Would really appreciate any help.

Edit: If I run lein repl in a folder that does not have any project.clj then it starts fine. And, it shows my clojure version as 1.10. So I am not sure why the error seems to suggest that I am using Clojure version older than 1.7.0

Thank you.

1 Answer

+1 vote
by
selected by
 
Best answer

Try lein deps :tree and you might see that one of those project dependencies, in turn states a requirement for an old Clojure.

You can overcome the problem by adding Clojure as a direct dependency:

[org.clojure/clojure "1.10.1"]
by
Thank you. Adding that worked! When I inspect the tree as you suggested, I see that one of them requires clojure/1.4.0.  
Thank you again. Hoping I can stick with clojure.
...