Welcome! Please see the About page for a little more info on how this works.

0 votes
in core.async by

Currently says:

"af must close! the channel before returning."

more correctly:

"af is responsible for closing the channel.", or similar.

af is asynchronous so should return immediately, the thread or go-block it spawns should close the channel later.

3 Answers

0 votes

Comment made by: pyr

I tend to find the suggested wording, I ended here while wanting to make sure I had understood the intent of the initial docstring correctly.

0 votes

Comment made by: glts

((link: ~pyr) There may be a word missing in the first clause of your comment?)

I cast my vote for this a while ago, but would prefer an even more explicit wording along the lines (native speaker input welcome):

"af must arrange for the channel to be closed eventually before returning."

Seems like an easy fix for a moderately upvoted issue, would you accept a patch for this? (If yes, is the policy to reflow the rest of the paragraph?)

0 votes
Reference: https://clojure.atlassian.net/browse/ASYNC-144 (reported by alex+import)